import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z][^:]+):(.*?)(?=^[A-Z][^:]+:|\\Z)";
final String string = "TITLE: some title\n"
+ "URL: some url\n"
+ "META: some meta\n"
+ "DATE: some date\n"
+ "AUTHOR(S): author\n"
+ "TEXT: some text\n"
+ "some more text\n"
+ "some more text2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}