$re = '/^([A-Z][^:]+):(.*?)(?=^[A-Z][^:]+:|\Z)/ms';
$str = 'TITLE: some title
URL: some url
META: some meta
DATE: some date
AUTHOR(S): author
TEXT: some text
some more text
some more text2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);