import re
regex = re.compile(r"^([A-Z][^:]+):(.*?)(?=^[A-Z][^:]+:|\Z)", flags=re.MULTILINE | re.DOTALL)
test_str = ("TITLE: some title\n"
"URL: some url\n"
"META: some meta\n"
"DATE: some date\n"
"AUTHOR(S): author\n"
"TEXT: some text\n"
"some more text\n"
"some more text2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")