using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<cve>CVE-\d{4}-\d{4})";
string input = @"(CVE-2020-1234)
(CVE-2020-12345)
(CVE-2018-123456)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}