$re = '/(?P<cve>CVE-\d{4}-\d{4})/m';
$str = '(CVE-2020-1234)
(CVE-2020-12345)
(CVE-2018-123456)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);