re = /(?P<cve>CVE-\d{4}-\d{4})/m
str = '(CVE-2020-1234)
(CVE-2020-12345)
(CVE-2018-123456)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end