package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:SERVICE_NAME|SID)\s*=\s*([^\r\n)]+)`)
var str = `SERVICE_NAME = text
SID = more`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}