re = /(?:SERVICE_NAME|SID)\s*=\s*([^\r\n)]+)/m
str = 'SERVICE_NAME = text
SID = more'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end