$re = '/(?:SERVICE_NAME|SID)\s*=\s*([^\r\n)]+)/m';
$str = 'SERVICE_NAME = text
SID = more';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);