#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).{0,}(\.jpg|\.gif).{0,}"
Local $sString = "http://www.gif.com/test.jpg" & @CRLF & _
"http://www.gif.com/test.html" & @CRLF & _
"http://gif.com/test.jpg" & @CRLF & _
"http://gif.com/test.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")