using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{0,}(\.jpg|\.gif).{0,}";
string input = @"http://www.gif.com/test.jpg
http://www.gif.com/test.html
http://gif.com/test.jpg
http://gif.com/test.html";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}