$re = '/.{0,}(\.jpg|\.gif).{0,}/m';
$str = 'http://www.gif.com/test.jpg
http://www.gif.com/test.html
http://gif.com/test.jpg
http://gif.com/test.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);