import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{3}([-.])\\d\\1|\\d{4})$";
final String string = "123-3-\n"
+ "123.4.\n"
+ "123-6.\n"
+ "123.7-\n"
+ "1234\n"
+ "12-34\n"
+ "123.4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}