re = /^(?:\d{3}([-.])\d\1|\d{4})$/m
str = '123-3-
123.4.
123-6.
123.7-
1234
12-34
123.4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end