$re = '/^(?:\d{3}([-.])\d\1|\d{4})$/m';
$str = '123-3-
123.4.
123-6.
123.7-
1234
12-34
123.4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);