#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^ # Début de chaîne" & @CRLF & _
"(?=(.*[0-9])) # Au moins 1 chiffre" & @CRLF & _
"(?=.*[a-z]) # Au moins 1 minuscule" & @CRLF & _
"(?=(.*[A-Z])) # Au moins 1 majuscule" & @CRLF & _
"(?=.*[\!@#$%^&*()\\[\]{}\-_+=~`|:;"'<>,.\/?]) # Au moins 1 caractère spéciale" & @CRLF & _
"(?=(.*)).{8,} # Au moins 8 caractères" & @CRLF & _
"$ # Fin de chaîne"
Local $sString = "azertyAZERTY123%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")