const regex = /^ # Début de chaîne
(?=(.*[0-9])) # Au moins 1 chiffre
(?=.*[a-z]) # Au moins 1 minuscule
(?=(.*[A-Z])) # Au moins 1 majuscule
(?=.*[\!@#$%^&*()\\[\]{}\-_+=~`|:;"'<>,.\/?]) # Au moins 1 caractère spéciale
(?=(.*)).{8,} # Au moins 8 caractères
$ # Fin de chaîne/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ # Début de chaîne
(?=(.*[0-9])) # Au moins 1 chiffre
(?=.*[a-z]) # Au moins 1 minuscule
(?=(.*[A-Z])) # Au moins 1 majuscule
(?=.*[\\!@#$%^&*()\\\\[\\]{}\\-_+=~`|:;"\'<>,.\\\/?]) # Au moins 1 caractère spéciale
(?=(.*)).{8,} # Au moins 8 caractères
$ # Fin de chaîne', 'gm')
const str = `azertyAZERTY123%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}