$re = '/^ # Début de chaîne
(?=(.*[0-9])) # Au moins 1 chiffre
(?=.*[a-z]) # Au moins 1 minuscule
(?=(.*[A-Z])) # Au moins 1 majuscule
(?=.*[\!@#$%^&*()\\\\[\]{}\-_+=~`|:;"\'<>,.\/?]) # Au moins 1 caractère spéciale
(?=(.*)).{8,} # Au moins 8 caractères
$ # Fin de chaîne/mx';
$str = 'azertyAZERTY123%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);