using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)(?'n'\d+))(?:(?<=^)(?P>n)(?=,))|(?:(?<=,)(?P>n)(?=$))|(?:(?<=,)(?P>n)(?=,))";
string input = @"60,15,22,39";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}