$re = '/(?(DEFINE)(?\'n\'\d+))(?:(?<=^)(?P>n)(?=,))|(?:(?<=,)(?P>n)(?=$))|(?:(?<=,)(?P>n)(?=,))/m';
$str = '60,15,22,39';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);