re = /(?(DEFINE)(?'n'\d+))(?:(?<=^)(?P>n)(?=,))|(?:(?<=,)(?P>n)(?=$))|(?:(?<=,)(?P>n)(?=,))/m
str = '60,15,22,39'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end