const regex = /threadId:(?<threadId>.*?)\s*\||correlationId:(?<correlationId>.*?)\s*\||userId:(?<userId>.*?)\s*\|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('threadId:(?<threadId>.*?)\\s*\\||correlationId:(?<correlationId>.*?)\\s*\\||userId:(?<userId>.*?)\\s*\\|', 'gm')
const str = `[INFO] 28 Jun 2018 14:02:29,480 SYSLOG->|datetime:20180628140229479+0000|hostname:marketingprofile-deployment-877c7f857-cv9d6/10.44.0.15(10.44.0.15)|threadId:47-http-nio-11551-exec-1 (main)|matchId:ferr-main|userId:null|correlationId:c7943b58-a584-4cba-ad44-45cf1af3a400|`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}