re = /threadId:(?<threadId>.*?)\s*\||correlationId:(?<correlationId>.*?)\s*\||userId:(?<userId>.*?)\s*\|/m
str = '[INFO] 28 Jun 2018 14:02:29,480 SYSLOG->|datetime:20180628140229479+0000|hostname:marketingprofile-deployment-877c7f857-cv9d6/10.44.0.15(10.44.0.15)|threadId:47-http-nio-11551-exec-1 (main)|matchId:ferr-main|userId:null|correlationId:c7943b58-a584-4cba-ad44-45cf1af3a400|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end