// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)threadId:(?<threadId>.*?)\s*\||correlationId:(?<correlationId>.*?)\s*\||userId:(?<userId>.*?)\s*\|").unwrap();
let string = "[INFO] 28 Jun 2018 14:02:29,480 SYSLOG->|datetime:20180628140229479+0000|hostname:marketingprofile-deployment-877c7f857-cv9d6/10.44.0.15(10.44.0.15)|threadId:47-http-nio-11551-exec-1 (main)|matchId:ferr-main|userId:null|correlationId:c7943b58-a584-4cba-ad44-45cf1af3a400|";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}