#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+\s*(.)\s*\w+\s*\1\s*\w+(?:(?!\1).)*$"
Local $sString = "one,three,four apple is red. match" & @CRLF & _
"" & @CRLF & _
"four, three, one orange is orange. match" & @CRLF & _
"" & @CRLF & _
"one,four,three the sky is blue. match" & @CRLF & _
"" & @CRLF & _
"one,two,four,three not match" & @CRLF & _
"" & @CRLF & _
"four,one,eight,green,three no match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")