using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+\s*(.)\s*\w+\s*\1\s*\w+(?:(?!\1).)*$";
string input = @"one,three,four apple is red. match
four, three, one orange is orange. match
one,four,three the sky is blue. match
one,two,four,three not match
four,one,eight,green,three no match";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}