package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{4})-(\d{2})-(\d{2})T(\d{2})\:(\d{2})\:(\d{2})$`)
var str = `2021-02-16T11:02:05
2021-02-16 11:02:05
2021-02-16
21-02-14
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}