$re = '/^(\d{4})-(\d{2})-(\d{2})T(\d{2})\:(\d{2})\:(\d{2})$/m';
$str = '2021-02-16T11:02:05
2021-02-16 11:02:05
2021-02-16
21-02-14
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);