re = /^(\d{4})-(\d{2})-(\d{2})T(\d{2})\:(\d{2})\:(\d{2})$/m
str = '2021-02-16T11:02:05
2021-02-16 11:02:05
2021-02-16
21-02-14
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end