use strict;
my $str = '<p> We love
<a href="https://google.com" rel="noopener noreferrer" target="_blank">Google</a>
and
<a href="Facebook.com" rel="noopener noreferrer" target="_blank">Facebook</a>.
<a href="www.example.com" rel="noopener noreferrer" target="_blank">Facebook</a>.
<a href="http://www.example.com" rel="noopener noreferrer" target="_blank">Facebook</a>.
</p>';
my $regex = qr/href="(?!https?:\/\/)()[^"]+"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}