import Foundation
let pattern = #"href="(?!https?:\/\/)()[^"]+""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p> We love
<a href="https://google.com" rel="noopener noreferrer" target="_blank">Google</a>
and
<a href="Facebook.com" rel="noopener noreferrer" target="_blank">Facebook</a>.
<a href="www.example.com" rel="noopener noreferrer" target="_blank">Facebook</a>.
<a href="http://www.example.com" rel="noopener noreferrer" target="_blank">Facebook</a>.
</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)