$re = '/href="(?!https?:\/\/)()[^"]+"/m';
$str = '<p> We love
<a href="https://google.com" rel="noopener noreferrer" target="_blank">Google</a>
and
<a href="Facebook.com" rel="noopener noreferrer" target="_blank">Facebook</a>.
<a href="www.example.com" rel="noopener noreferrer" target="_blank">Facebook</a>.
<a href="http://www.example.com" rel="noopener noreferrer" target="_blank">Facebook</a>.
</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);