using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(\b\w{4,}\b)(?:.*\b\1\b){2,})";
string input = @"word word word
notword word word
avoid a match in >word< word word word, and match word >word< word word?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}