const regex = /(?=(\b\w{4,}\b)(?:.*\b\1\b){2,})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(\\b\\w{4,}\\b)(?:.*\\b\\1\\b){2,})', 'g')
const str = `word word word
notword word word
avoid a match in >word< word word word, and match word >word< word word?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}