$re = '/(?=(\b\w{4,}\b)(?:.*\b\1\b){2,})/';
$str = 'word word word
notword word word
avoid a match in >word< word word word, and match word >word< word word?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);