import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(\\b\\w{4,}\\b)(?:.*\\b\\1\\b){2})(?!(\\b\\w{4,}\\b)(?:.*\\b\\1\\b){3})";
final String string = "www dogs ccc cat dogs dogs banana \n"
+ "dogs cats cats cats dogs apples dogs cats cats\n"
+ "notword something word word\n"
+ "wordx abcd word word abcd abcdx\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}