$re = '/(?=(\b\w{4,}\b)(?:.*\b\1\b){2})(?!(\b\w{4,}\b)(?:.*\b\1\b){3})/m';
$str = 'www dogs ccc cat dogs dogs banana
dogs cats cats cats dogs apples dogs cats cats
notword something word word
wordx abcd word word abcd abcdx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);