const regex = /(?=(\b\w{4,}\b)(?:.*\b\1\b){2})(?!(\b\w{4,}\b)(?:.*\b\1\b){3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(\\b\\w{4,}\\b)(?:.*\\b\\1\\b){2})(?!(\\b\\w{4,}\\b)(?:.*\\b\\1\\b){3})', 'gm')
const str = `www dogs ccc cat dogs dogs banana
dogs cats cats cats dogs apples dogs cats cats
notword something word word
wordx abcd word word abcd abcdx
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}