re = /(["']).*?\1/
str = '<span style="font-size:0.58em;font-family:\'Times New Roman\';">
<span style=\'font-size:0.58em;font-family:"Times New Roman";\'>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end