const regex = new RegExp('(\\S+(?: \\S+)*): *(\\S+(?: \\S+)*)', 'gm')
const str = `OK
AT!GSTATUS?
!GSTATUS:
Current Time: 2420 Temperature: 30
Reset Counter: 1 Mode: ONLINE
System mode: LTE PS state: Attached
LTE band: B30 LTE bw: 10 MHz
LTE Rx chan: 1234 LTE Tx chan: 12345
LTE CA state: NOT ASSIGNED
EMM state: Registered Normal Service
RRC state: RRC Idle
IMS reg state: No Srv
PCC RxM RSSI: -74 RSRP (dBm): -103
PCC RxD RSSI: -74 RSRP (dBm): -104
Tx Power: 0 TAC: 123A (1234)
RSRQ (dB): -12.4 Cell ID: 1234AB56 (12345678)
SINR (dB): 9.4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}