# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\S+(?: \S+)*): *(\S+(?: \S+)*)"
test_str = ("OK\n"
"AT!GSTATUS?\n"
"!GSTATUS:\n"
"Current Time: 2420 Temperature: 30\n"
"Reset Counter: 1 Mode: ONLINE\n"
"System mode: LTE PS state: Attached\n"
"LTE band: B30 LTE bw: 10 MHz\n"
"LTE Rx chan: 1234 LTE Tx chan: 12345\n"
"LTE CA state: NOT ASSIGNED\n"
"EMM state: Registered Normal Service\n"
"RRC state: RRC Idle\n"
"IMS reg state: No Srv\n\n"
"PCC RxM RSSI: -74 RSRP (dBm): -103\n"
"PCC RxD RSSI: -74 RSRP (dBm): -104\n"
"Tx Power: 0 TAC: 123A (1234)\n"
"RSRQ (dB): -12.4 Cell ID: 1234AB56 (12345678)\n"
"SINR (dB): 9.4")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.