const regex = /PROMPT \d+:\n(?<value>(?:.+(?:\n\n|$))+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('PROMPT \\d+:\\n(?<value>(?:.+(?:\\n\\n|$))+)', 'g')
const str = `PROMPT 1:
User: Why did the kangaroo bring a mattress to the comedy show?
Assistant: I'm not sure, why did the kangaroo bring a mattress to the comedy show?
User: Because it wanted to have a "hop"-in good time and "bounce" back with laughter!
PROMPT 2:
User: What do you call a group of musical elephants?
Assistant: I don't know, what do you call a group of musical elephants?
User: A "trumpet" ensemble, because they sure know how to "trunk"-ate their talent!
PROMPT 3:
User: What did the chicken say to the comedian?
Assistant: I don't know, what did the chicken say to the comedian?
User: "You crack me up!" Although, I guess that's their job too, cluck it up already!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}