use strict;
my $str = 'PROMPT 1:
User: Why did the kangaroo bring a mattress to the comedy show?
Assistant: I\'m not sure, why did the kangaroo bring a mattress to the comedy show?
User: Because it wanted to have a "hop"-in good time and "bounce" back with laughter!
PROMPT 2:
User: What do you call a group of musical elephants?
Assistant: I don\'t know, what do you call a group of musical elephants?
User: A "trumpet" ensemble, because they sure know how to "trunk"-ate their talent!
PROMPT 3:
User: What did the chicken say to the comedian?
Assistant: I don\'t know, what did the chicken say to the comedian?
User: "You crack me up!" Although, I guess that\'s their job too, cluck it up already!';
my $regex = qr/PROMPT \d+:\n(?<value>(?:.+(?:\n\n|$))+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}