re = /PROMPT \d+:\n(?<value>(?:.+(?:\n\n|$))+)/
str = 'PROMPT 1:
User: Why did the kangaroo bring a mattress to the comedy show?
Assistant: I\'m not sure, why did the kangaroo bring a mattress to the comedy show?
User: Because it wanted to have a "hop"-in good time and "bounce" back with laughter!
PROMPT 2:
User: What do you call a group of musical elephants?
Assistant: I don\'t know, what do you call a group of musical elephants?
User: A "trumpet" ensemble, because they sure know how to "trunk"-ate their talent!
PROMPT 3:
User: What did the chicken say to the comedian?
Assistant: I don\'t know, what did the chicken say to the comedian?
User: "You crack me up!" Although, I guess that\'s their job too, cluck it up already!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end