using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)(?:\(.*\))END$";
string input = @"START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end ()END
START OF THE SHOW with some gibberish characters () also lots of non-sense things () with boring end ()END
START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end (III)END
START OF THE SHOW with some gibberish characters (1) also lots of non-sense things (2) with boring end (3)END
START OF THE SHOW with some gibberish characters (111) also lots of non-sense things (222) with boring end (333)END";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}