import Foundation
let pattern = #"^(.*?)(?:\(.*\))END$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end ()END
START OF THE SHOW with some gibberish characters () also lots of non-sense things () with boring end ()END
START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end (III)END
START OF THE SHOW with some gibberish characters (1) also lots of non-sense things (2) with boring end (3)END
START OF THE SHOW with some gibberish characters (111) also lots of non-sense things (222) with boring end (333)END
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)