import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)(?:\\(.*\\))END$";
final String string = "START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end ()END\n\n"
+ "START OF THE SHOW with some gibberish characters () also lots of non-sense things () with boring end ()END\n\n"
+ "START OF THE SHOW with some gibberish characters (I) also lots of non-sense things (II) with boring end (III)END\n\n"
+ "START OF THE SHOW with some gibberish characters (1) also lots of non-sense things (2) with boring end (3)END\n\n"
+ "START OF THE SHOW with some gibberish characters (111) also lots of non-sense things (222) with boring end (333)END";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}