package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:@Test)+.*(?:@Conditional)+|(?:@Conditional)+.*(?:@Test)+`)
var str = `@Conditional @Test
@Test @Conditional
@Conditional
@Test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}