import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:@Test)+.*(?:@Conditional)+|(?:@Conditional)+.*(?:@Test)+";
final String string = "@Conditional @Test\n"
+ "@Test @Conditional\n"
+ "@Conditional\n"
+ "@Test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}