re = /(?:@Test)+.*(?:@Conditional)+|(?:@Conditional)+.*(?:@Test)+/m
str = '@Conditional @Test
@Test @Conditional
@Conditional
@Test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end